
FIL 240 & 404 – Trefzger 

SPREADSHEET PROBLEM 1 

Computing Future Balance in Retirement Savings Acct (Special Feature: Creating Time Value Formulas) 

 

This exercise involves someone who plans to deposit regular annual amounts into a tax-favored savings 

plan such as the Roth Individual Retirement Account.  (With an untaxed account we can project the 

money the saver will have at retirement without having to speculate on how the investment earnings 

would be taxed in a taxable arrangement.)  The saver plans to make deposits at the start of each year for 

40 working years, and then to retire at the end of the 40th year.  Thus the saver makes deposits from, for 

example, age 25 through 64 (choose any age for the saver’s first deposit, but make sure the template you  

set up works correctly for 40 beginning-of-year deposits).  Annual Roth IRA deposit ceilings change over 

time, so just make reasonable assumptions about the amount the saver will deposit each year, and about 

the average after-tax annual rate of return the saver will earn.  But do assume that the saver’s deposits  

will increase (or decrease, if you prefer) in these stages: one amount in years 1 – 6, a different amount  

in years 7 – 30, and a third amount in years 31 – 40.  (Do not submit the $3,100/$4,200/$5,300/4.35% 

figures used in the sample output, which is there to help verify that your template is correct before you 

choose final numbers for the version you submit; use other dollar and return values.  And construct the 

spreadsheet so if the user changes Input Section values all Output Section values change automatically; 

cells the computations are based on should contain formulas or cell references and not just typed-in 

numbers; we want this spreadsheet to be a versatile retirement planning tool.  But do not use time periods 

other than years 1 – 6, 7 – 30, and 31 – 40; otherwise the grader can not easily confirm your numbers.)    

 

The key to analyzing a long-term savings plan is understanding compound interest or, more generally, 

compound rates of return.  The amount to which a deposit grows over time can be computed as 

Deposit x (1 + percentage periodic rate of return) number of time periods. 

For example, if you put $1,000 in an account today and it grows at a 5% average rate per year, then after 

4 years the $1,000 will have grown to 

$1,000 x (1.05)4 = $1,215.51. 

Note that the  $1,000.00 grows to ($1,000.00 x 1.05) = $1,050.00 by the end of year 1. 

Then the  $1,050.00 grows to ($1,050.00 x 1.05) = $1,102.50 by the end of year 2. 

Then the  $1,102.50 grows to ($1,102.50 x 1.05) = $1,157.63 by the end of year 3. 

Finally, the  $1,157.63 grows to ($1,157.63 x 1.05) = $1,215.51 by the end of year 4. 

 

This relationship is the basis for the computations in this exercise, in which we introduce non-linear 

relationships by using exponents (indicated by the ^ sign when you enter information in the spreadsheet 

program).  So you should compound each expected deposit to its future value (with the target future date 

being the saver’s retirement date), and sum the individual future values to find the balance you expect to 

see in the account when the saver retires.  Then add the cell values representing expected retirement-day 

totals for the groups of equal deposits (compounded totals for deposits from years 1 – 6, years 7 – 30,  

and years 31 – 40).  Finally, you should see that this type situation is an example of a future value of  

a sequential annuity due problem, and should solve it as such in addition to summing the individual 

deposits’ future values.  Note that the expected retirement-day totals computed all three ways should be 

the same if your template is designed correctly, and that the sub-totals for the groups of deposits should 

be the same whether computed line-by-line or computed independently with the annuity approach.  

____________________________________________________________________________________ 

 

A set of fairly detailed instructions is provided for your use [starting on page 2 below], should you want 

to use it.  You can try to develop a creative solution to the problem on your own, but be sure that you 

show all of the main computational steps assigned and the related output.  Please upload your finished 

spreadsheet to Reggie Net (or print your output on one page if we are collecting paper copies; using less 

paper saves money and trees, and the grading process is easier with less page-flipping). 

 

WHAT YOU HAND IN SHOULD BE YOUR OWN INDIVIDUALLY-COMPLETED, ORIGINAL 

WORK.  OUR SPREADSHEET ASSIGNMENTS ARE NOT GROUP PROJECTS OR CUT-AND-

PASTE EXERCISES. 
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You might try to develop a creative solution to the problem on your own, but the following set of fairly 

detailed instructions is provided for anyone who wants to make use of it.  These instructions are for 

working the above problem with the Microsoft Excel spreadsheet software; other spreadsheet packages 

might not require identical steps.  Again, the procedure described is a method for using the computer to 

solve the problem; it is not the only possible method.  But whatever method you use should include all  

the assigned steps noted in the statement of the problem, and should lead to correct Output Section values 

when the few Input Section cell values are changed.  When a blank spreadsheet page appears on the 

screen of the computer monitor, you are ready to begin following the instructions.  Remember to “Save” 

every few minutes.  The instructions may be unclear in a few places, despite the instructor’s best efforts; 

ask questions when in doubt.  If you follow the directions as specified and nothing seems to happen, try 

hitting “Enter” before proceeding.  You can move the indicator that highlights a cell by hitting one of the 

keys that shows an arrow pointing up, down, left, right, etc.  If a cell shows a series of ####### marks, 

you need to make your column wider by positioning the mouse “cross” at the edge of the desired column 

in the top row of the spreadsheet (where the letters A, B, C, etc. appear) and left-clicking, then dragging 

the mouse until you have the desired width (or just double-click and it should adjust automatically to a 

width sufficient to show the values). 

 

In cell A1 type your name.  In cell A2 type information to identify the problem you are working and the 

type of situation it addresses.  In cells A4 through A7, type a brief narrative telling about the situation 

whose outcome you are trying to compute.   

 

In cell A9 type “INPUT SECTION.”  In cell A10 type “Amount Deposited at Beginning of Each of Years 

1 – 6,” in cell A11 type “Amount Deposited at Beginning of Each of Years 7 – 30,” and in cell A12 type 

“Amount Deposited at Beginning of Each of Years 31 – 40.”  In cell A13 type “Expected Average 

Annual After-Tax Rate of Return,” in cell A14 type “Expected Number of Deposits,” and in cell A15 type 

“Age When First Deposit Is Made.”  In cell E10 type whatever dollar value you choose as your year 1 – 6 

annual deposit, in cell E11 type your year 7 – 30 annual deposit, and in cell E12 type your year 31 – 40 

annual deposit (and then in Cells under the Format menu format each of these three cells as currency, 

with two decimal places).  In cell E13 type whatever percentage rate you choose as your expected average 

annual rate of return (and then in Cells under the Format menu format the cell as a percentage with two 

decimal places, so that if you select .055 the cell will show 5.50%).  In cell E14 type “40” as the number 

of years in which deposits are expected to be made (do not choose a value other than 40; that cells’ value 

will be used in some computations to be completed below), and in cell E15 type whatever age seems 

reasonable for making the initial deposit.   

 

In cell A17 TYPE “output section,” and in cells A18 and A19 type a brief narrative telling that your 

computations involve summing the individual deposits’ compounded future values and then the grouped 

deposits’ compounded values.  In cell A23, type “year,” in cells B21 through B23, type “Age at 

Beginning of Year,” in cells C21 through C23 type “Remaining Years Until Retirement,” in cells D22 

and D23 type “Annual Deposit,” in cells E22 and E23 type “Future Value Factor,” in cells F21 – F23  

type “Value of Deposit at Retirement,” and in cells G21 – G23, type “Sum of Values of Equal Deposits  

at Retirement.”   

 

In cell A24 type the number 1, and then in cell A25 type “=A24+1.”  In cell B24 type “=E16” (the age 

you choose for the first deposit), and then in cell B25 type “=B24+1.”  (These columns are there only  

for cosmetic purposes; the computations are not affected by columns A and B, but rather are affected by 

column C, which contains the number of years remaining until the expected retirement date.)   

 

In cell C24 type “=E14” and in cell C25 type “=C24-1.”  (These steps establish the number of years – 40 

and 39 – that the 1st and 2nd deposits, respectively, will compound before the expected retirement date.)  

In cell D24 type “=$E$10” (and type the same thing in cell D25) [the dollar signs do not indicate money; 

rather, they instruct the computer to keep getting information from the exact same cell, rather than using 

relative cell addresses and seeking input values by moving down the spreadsheet as you move to higher-

numbered rows].  In cell E24 type “=(1+$E$13)^C24” and in E25 type “=(1+$E$13)^C25.”  In cell F24 
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type “=D24*E24” and in cell F25 type “=D25*E25.”  Highlight cells A25 through F25.  Under the Edit 

menu select Copy.  Highlight the block of cells A26 through F63.  Under the Edit menu select Paste.  

There now should be numbers in all of cells A24 through F63.  But you do not want to show the same 

deposit in each of the 40 years, so in cell D30 type, “=$E$11.”  Then highlight cell D30, select Copy 

under the Edit menu, highlight the range of cells D31 through D53, and select Paste under the Edit menu.  

Then in cell D54 type, “=$E$12.”  Then highlight cell D54, select Copy under the Edit menu, highlight 

the range of cells D55 through D63, and select Paste under the Edit menu.  Now all of your deposits 

should show correctly, and your individual computations should be complete and ready for summing.       

 

In cell D65 type “=SUM(D24:D63),” and in F65 type “=SUM(F24:F63).”  (You might want to format all 

the values in columns D and F as currency, with two decimal places shown.)  In cells D66 and D67 type 

“Total Deposits,” and in cells F66 – F68 type “Compounded Value of Individual Deposits.”  Now you 

can look at cell F65 and find out how much is expected to be in the account at the end of 40 years, based 

on the regular deposits specified in cells E10 – E12 and the rate of return specified in cell E13.   

 

Now create groups of the equal deposits.  In cell G29 type “=SUM(F24:F29),” in cell G53 type 

“=SUM(F30:F53),” and in cell G63 type “=SUM(F54:F63).”  Then in cell G65 type “=SUM(G24:G63),” 

and in cells G66 – G68, type “Compounded Value of Grouped Deposits.”  The independently computed 

values shown in cells F65 and G65 should be equal.   

 

What we have done here is a line-by-line or grouped analysis showing the progressive buildup in a future 

value of an annuity situation (annuity due because the deposits are made at the beginning of each year).  

We can more directly compute the future value of an annuity due based on the formula  

 

Regular deposit (
(1+𝑟)𝑛−1

𝑟
) (1 + r) = Ending Balance . 

 

But here we have a sequence of annuities, with the year 1 – 6 and the year 7 – 30 deposit streams ending 

long before the retirement date, such that they will be reinvested until the end of year 40.  For example, 

the year 1 – 6 deposits (let’s say $3,100 per year) will be worth $18,600-plus-interest (let’s say at 4.35%) 

by the end of year 6, but then will continue to earn interest for 34 more years until the end of year 40: 

 

$3,100 (
(1.0435)6−1

.0435
) ∙ (1.0435) ∙ (1.0435)34  = $21,646.33 (4.253470) = $92,072.01 . 

 

In cell A70 type a brief narrative to show that we will be computing the future values of a sequence of 

level annuities due.  In cell D73 type “Annual Deposit,” cell E73 type “Annuity Factor,” in cells F72 and 

F73 type “Compounding Factor,” in cells G72 and G73 type “Truncated Annuity Factor,” and in cells 

H71 – H73 type “Compounded Value of Annuities.”  In cells A74 – A77 type labels to indicate that you 

are working with the year 31 – 40, year 7 – 30, and year 1 – 6 deposit streams, and the combined total, 

respectively.   In cells D74 – D76 type “=E12,” “=E11,” and “=E10,” respectively.  Then in E74 type 

“=(((1+E13)^10)-1)/E13*(1+E13),” and in cell F74 type “=(1+E13)^0.” In E75 type “=(((1+E13)^24)-

1)/E13*(1+E13),” and in F75 type “=(1+E13)^10.”  Then in E76 type “=(((1+E13)^6)-1)/E13*(1+E13),” 

and in cell F76 type “=(1+E13)^34.”      

 

In cell G74 type “=E74*F74,” and in cell H74 type “=D74*G74.”  Then highlight cells G74 and H74, 

select Copy under the Edit menu, highlight cells G75 through H76, and select Paste under the Edit menu.  

Cells H74 – H76 now should show the compounded values of the three individual annuity streams.  

(These individual totals should equal the independently computed grouped totals shown in cells G29, 

G53, and G63 above, in the opposite order since in the annuity computations we happened to deal with 

the last 10 years first.)  Finally in cell H77 type “=SUM(H74:H76).”  Cell H77 should show the same 

value that was computed independently in cells F65 and G65.  Thus we see that the future value of an 

annuity, or of a group of annuities, can be computed as the FV of a series of individual dollar amounts  

or grouped dollar amounts over the same time period.  Annuity computations are just an efficient way of 

treating groups of equal or related payments as a team.   
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With this spreadsheet we can instantaneously compute a new answer when we change one or more of the 

deposit levels or the expected rate of return in cells E10 – E12 or E13 (although we can not easily change 

the number of deposits, since the sheet is constructed explicitly for 40 years).  For example, do a trial run 

with deposits of $3,100, $4,200, and $5,300, and a 4.35% average expected annual rate of return.  Note 

that (for those numbers, anyway) the compounded value arising from the first 6 deposits is greater than 

the compounded value of the last 10 deposits, even though each of the last 10 deposits is considerably 

larger than each of the first 6 deposits, because the total from those initial 6 deposits grows at interest for 

a significant 34 additional years before the saver retires.  Lesson for life: Start saving/investing early, and 

stay with your plan.  Even if the rate of return is not terribly high, you can reach a high total if you can 

make deposits for many years before retiring.   

 

Try several deposit and rate combinations in Input Section cells E10 – E12 and E13 to see how the total  

in cell F67 (or the equivalent amount independently computed in cell G65 or H77) would change by the 

retirement date.  Choose a combination that you like, and submit the result; the sample output page gives 

an idea of what your result should look like if you complete all of the assigned steps.  (It is good to check 

your work by using $3,100/$4,200/$5,300 and 4.35%, and comparing your results with the sample output 

provided, but then the example you hand in should be based on different dollar and rate of return figures.) 

 

Make your output look better by formatting the dollar values as currency; highlight the relevant cells and 

then right-click and select “Format Cells.”  Then click on currency, specifying two decimal places. 

 

PLEASE UPLOAD YOUR FINISHED ASSIGNMENT TO REGGIE NET IF WE ARE KEEPING 

TRACK OF HOMEWORK ON THE REGGIE NET ASSIGNMENTS TAB.     

 

PRINTING (if we are printing rather than uploading to Reggie Net): 

To print the entire spreadsheet, highlight the entire range of cells A1 through H77.  Then under the “File” 

menu choose “Print.”  Under the Settings heading click on the down arrow next to the “Print Active 

Sheets” box and choose “Print Selection” from the choices that drop down.  On the right you should see  

a preview of what your output will look like.  (If you don’t like what you see you will have to exit Print 

mode and do some reformatting, for example by centering words/numbers within columns, using bold 

print or italics or underlining, or changing column widths, and then again choose “File,” “Print,” and 

“Print Selection” as above.)  Please try to keep your printed output all on one page by clicking “Page 

Setup” at the bottom of the screen, then clicking on the circle for “Fit to 1 page by 1 page,” and then 

clicking on “OK” before printing.  (Your printer or software might not allow you to print it all on one 

page, but let’s save trees if possible – plus the grading is much easier if everyone prints on one page.)   

Be sure to retain your original electronic file as a backup in case we can not find your printed copy.      

 

A sample of what your output might look like, if it includes all the assigned steps, appears in the sample 

output file accompanying this assignment on the course web site.  I hope this project proves to be an 

educational and not-too-gruesome experience. 

 

WHAT YOU SUBMIT SHOULD BE YOUR OWN INDIVIDUALLY-COMPLETED, ORIGINAL 

WORK.  OUR SPREADSHEET ASSIGNMENTS ARE NOT GROUP PROJECTS, OR CUT-AND-

PASTE EXERCISES BASED ON THE SAMPLE OUTPUT.  
 


